Home Uncategorized Deloitte NLA – Sample Questions and Answers 

Deloitte NLA – Sample Questions and Answers 

by Anup Maurya
27 minutes read

Deloitte NLA – Sample Questions and Answers 2024.

Quants and Logical

1. Four of the following five are alike in a certain way and so form a group. Which is the one that does not belong to that group?
1) Cricket
2) Football
3) Polo
4) Carrom
5) Hockey

2. In the word CONTRACTUAL, the positions of the first and the eleventh letters are interchanged. Similarly, the positions of the second and the tenth letters are interchanged, and so on, up to the positions of fifth and seventh letters are interchanged, keeping the position of sixth letter unchanged. Which letter will be the third to the right of the sixth letter from the left end?
1) U
2) N
3) T
4) A
5) None of these

3. In a certain code, LATE is written as $%#@ and WIDE is written as *?▲@. How is DIAL written in that code?
1) ▲@#$
2) ▲@%$
3) ▲?%$
4) ▲?%#
5) None of these

4. What will come in place of the question mark (?) in the following series based on their positions in the English alphabet?
DGH JMN ? VYZ
1) PRS
2) QST
3) OQR
4) ORS
5) None of these

5. If in the following set of numbers, the first and the third digits are interchanged in each number, which number will be second if arranged in ascending order after interchanging the digits?
583 645 396 287 469
1) 583
2) 645
3) 396
4) 287
5) 469

Directions (Q.6-10): In each of the following questions two rows of numbers are given. The resultant of each row is to be worked out separately based on the following rules, and the question below the row of numbers is to be answered. The operations of numbers in each row progress from left to right.

Rules:
(i) If an odd number is followed by another odd number, they are to be multiplied.
(ii) If an even number is followed by another even number, the first number is to be divided by the second even number.
(iii) If an even number is followed by the perfect square of an odd number, the first number is to be subtracted from the second number.
(iv) If an odd number is followed by an even number the two are to be added.
(v) If an even number is followed by an odd number which is not a perfect square, the square of the odd number is to be added to the even number.

11. 96 16 81 = x
11 15 18 = y

What is the value of y-2x?
1) 108
2) 33
3) 105
4) 36
5) None of these

12. 28 49 13 = x
37 12 22 = y

What will be the sum of the resultant of the two rows?
1) 108
2) 244
3) 102
4) 344
5) None of these

13. 18 5 17 = x
64 8 11 = y

What will be the value of x + y?
1) 189
2) 129
3) 69
4) 169
5) None of these

14. 9 15 50 = x
12 25 24 = y
What will be the value of x/y?
1) 18
2) 8
3) 5
4) 6
5) None of these

15. 56 14 9
36 12 7

What will be the difference between the resultants of the two rows?
1) 14
2) 21
3) 5
4) 26
5) None of these

Answers:

1. (4)
2. (2)
3. (3)
4. (5)
5. (2)
6. (2)
7. (4)
8. (5)
9. (3)
10. (5)
11. (1)
12. (2)
13. (1)
14. (3)
15. (4)

Coding Question

Momentum LinkedList

Problem Statement :

Ratul made a linked list, a list made of n nodes, where every node has two variables, the velocity and the mass of a particle.
Since all the particles have the velocity in the same direction, find the total momentum of the entity made by the particles from the linked list.

Constraints :
1<=n<=10000
1<=m,v<=100
Input format:
First line containing n, number of nodes
Then n lines containing the mass and the velocity space separated.
Output Format:
Single integer denoting the momentum

Sample Input:
4
1 3
2 4
2 3
4 5

Sample Output:
37

#include <bits/stdc++.h>

using namespace std;

int main() {
  int n, s = 0, m, v;
  cin >> n;
  for (int i = 0; i < n; i++) { cin >> m >> v;
    s += (m * v);
  }
  cout << s;
}

Lazy String

Problem Statement :

Anish is the laziest person you can ever see. He is tasked to write the name of the winner in a game where two people take part. And he just writes the longest common subsequence over there, so that with minimum chane or no backspace he can edit the name to the winner’s name.
For two given names, you have to predict what Anish will write in his computer before the start of the name. If there are more than two longest subsequences possible,write the one with less lexicographic value.
Input Format:
Two lines including two strings of name(All with capital letters)

Output Format:
A single line with the lexicographically smallest possible longest common subsequence.

Sample Input:
ABCD
BACD
Sample Output:
ACD
Explanation:
ACD and BCD these are the two possible biggest substring

#include <bits/stdc++.h>

using namespace std;
string s1, s2, s3;

int fun(int i, int j, int k, string s) {
  if (i == s1.length() || j == s2.length()) {
    if (s3.length() == s.length()) s3 = min(s, s3);
    else if (s3.length() < s.length()) s3 = s; return k; } if (s1[i] == s2[j]) return fun(i + 1, j + 1, k + 1, s + s1[i]); return max(fun(i + 1, j, k, s), fun(i, j + 1, k, s)); } int main() { cin >> s1 >> s2;
  fun(0, 0, 0, "");
  cout << s3;
}

related posts

Leave a Comment